⇒ Better Structure = Higher Grades

⇒ Referencing made easy!

⇒ Great essay templates!

⇒ Make essays as good as your ideas!


  • Remove the stress of referencing
  • Reduce the chances of accidental plagiarism
  • Accurate referencing improves grades
  • Makes the writing process more efficient
  • Unique 3D Viewer
  • ideamapper4studentsAT contains all the features of regular ideamapper, but with added referencing functionality.
  • The quick and simple referencing tool within ideamapper4studentsAT helps students create accurate, well referenced documents.
  • References can be automatically formatted using a variety of fully customizable styles, so students can be sure that their college referencing style can be replicated.
  • 100’s of templates included.
  • Compatible with Windows, Mac OS and Linux.
Created for students with assistive technology needs, ideamapper4studentsAT includes additional features such as:
  • Phrase bank to help students overcome blank page brain fog
  • Paragraph highlighting which helps students use better more concise structuring
  • Text to speech—helping students with literacy and comprehension issues

Try now for FREE!

ideamapper4students

ideamapper

IdeaMapper4Students and IdeaMapper4StudentsAT use the same installer.
When you enter the license key for the AT edition the program will unlock the AT features.If you wish to trial the AT features simply select "Idea Mapper 4 Students AT" when choosing the 30 day trial in the licensing wizard.

ideamapper System Requirements

Windows: 1 GHz Intel Pentium or compatible processor, Microsoft Windows 7, 8 or 10 operating system, 2 GB of RAM, 100 MB of free hard disk space, color screen with 1024x768 resolution.
Mac OS: 2 GHz Intel processor, Apple macOS 10.13, 10.14 or 10.15, 4 GB of RAM, 100 MB of free hard disk space, color screen with 1024x768 resolution.
Linux: 2 GHz Intel processor, Ubuntu Linux 18.04 LTS, other Linux distributions may work, 4 GB of RAM, 100 MB of free hard disk space, color screen with 1024x768 resolution.
Browser Beta: Requires WebAssembly support in the browser, recent versions of Google Chrome (minimum version 57), Mozilla Firefox, Apple Safari and New Microsoft Edge should work. [THIS IS A BETA, PRE-RELEASE VERSION, PLEASE READ THIS ARTICLE FOR MORE INFORMATION: Browser Beta Version Information.].